Erreur de base de données

Quelque chose ne fonctionne pas? Faites le savoir. (un post par problème)
Avatar de l’utilisateur
Zoliv
Messages : 348
Inscription : 01 janv. 2014, 13:29

Erreur de base de données

Message par Zoliv » 18 juin 2018, 15:38

Bonjour ! J'essaie de monter la compétence Ingénierie ! la seul méthode que je connais est de brancher /débrancher le matériels dans l'onglet système !
J'ai eu cette erreur en voulant larguer un de mes nombreux déchet :
Erreur : Impossible d'effectuer la requete Base fermée. [SELECT `oada_structure_mod` modstructure, `oada_energy_mod` modenergy, `oada_shield_mod` modshield, `oada_conspeed_mod` modconvspeed, `oada_hyperspeed_mod` modhyperspeed, `oada_cargo_mod` modcargo, `oada_compower_mod` modcomppower, `oada_compmemory_mod` modcompmem, `oada_solar_panel_mod` modsolarpanel, `oada_reparing_droid_mod` modrepairingdroid, `oada_life_capacity_mod` modlifecapacity, `oada_visible` devicevisible, `oada_maximaluse` devicemaxuse , `oada_slot_type` deviceslottype FROM `oba_device_abstraction` WHERE `oada_oba_id` = 51 LIMIT 0, 1 ]

J'obtiens ce message dès que je vais dans l'onglet système de mon vaisseau "USS Exploreur NCC 7609-B"

je pense que je vais racheter un "USS Exploreur NCC 7609-C" pour continuer !
Orlean de Skylon
Capitaine de la Petite Elise VI, USS Exploreur NCC 7609-A, et de LaBelleSandra
TOP 1 de la guilde des marchands, ex Empereur Marchand (19), Undef (??)
Encyclopédiste autoproclamé de lunastars

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 12:25

Bonjour,
Dans Cosmoport je constate une erreur quand je clique sur "Guilde":
" Erreur système : Trying to get property 'date' of non-object"

Je constate une autre erreur dans la base de donnée:
" Erreur système : count(): Parameter must be an array or an object that implements Countable"
qui apparait quand je suis sur Cosmoport et que je tente de cliquer sur n'importe quel autre onglet sauf "profil" et "spatioport".

L'erreur de base de donnée arrive quand je veux "décoller":
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`event`.`id_eve` at row 1 [INSERT INTO `event` ( `id_eve`, `eve_date`, `eve_type`, `eve_coo_id`)VALUES ('', NOW( ), '3', '2');]"
Dernière modification par gugus2000 le 16 févr. 2020, 18:19, modifié 1 fois.
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 12:39

Chose intéressante:
après le message d'erreur, quand je me reconnecte, je suis sur la baie d'amarrage et je peux accéder à tout les onglets
Par contre si je veux "décoller":
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`event`.`id_eve` at row 1 [INSERT INTO `event` ( `id_eve`, `eve_date`, `eve_type`, `eve_coo_id`)VALUES ('', NOW( ), '4', '2');]"

Si je me reconnecte je suis bien sur le poste de commande accroché à Cosmoport comme normalement avec, de la même façon, un accès à tous les onglets.
Lorsque je "décroche" de Cosmoport:
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`event`.`id_eve` at row 1 [INSERT INTO `event` ( `id_eve`, `eve_date`, `eve_type`, `eve_coo_id`)VALUES ('', NOW( ), '5', '2');]"

Je me reconnecte et je suis bien décroché de la station.
Je vais vers le nord:
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`event`.`id_eve` at row 1 [INSERT INTO `event` ( `id_eve`, `eve_date`, `eve_type`, `eve_coo_id`)VALUES ('', NOW( ), '9', '2');]"
Si je me reconnecte, je n'ai pas bougé! (malgré plusieurs essais)

Le ré-engagement sur cosmoport se fait aussi avec des message d'erreur, mais fonctionne à la reconnexion (pareil pour tout le reste jusqu'à "monter à bord", qui produit les mêmes message d'erreur aux différents onglets)
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 12:43

je penses que l'erreur de la base de données vient de l'espace manquant entre ")" et "VALUES", ou une confusion entre string et int.
(D'aileurs, il vaut mieux passer par les requêtes préparé plutôt que les requetes non préparé)
Je peux essayer d'aider si ça peut être utile :)
Dernière modification par gugus2000 le 16 févr. 2020, 18:20, modifié 1 fois.
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 15:10

Autres infos: si j'essaie d'envoyer un message dans le canal publique:
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`hypermessage`.`id_hym` at row 1 [INSERT INTO `hypermessage` (`id_hym`, `hym_comnet_id`, `hym_poster_id`, `hym_hca_id`, `hym_type`, `hym_title`, `hym_content`, `hym_duration`) VALUES ('', '2', '922', '1', 'content', 'Coucou', 'Il y a quelqu\'un ?\r\nSi oui, arrivez-vous "
Je ne comprend pas comment la colonne 'lunav2' est concerné alors qu'elle n'est pas utilisé ici... :/
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 15:12

Nouvelle erreur pour "fixer le cap" :D :
"Erreur : Impossible d'effectuer la requete :Incorrect integer value: '' for column `lunav2`.`event`.`id_eve` at row 1 [INSERT INTO `event` ( `id_eve`, `eve_date`, `eve_type`, `eve_coo_id`)VALUES ('', NOW( ), '49', '2');]", encore cette colonne :?
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Avatar de l’utilisateur
gugus2000
Messages : 86
Inscription : 17 avr. 2015, 19:55
Localisation : France
Contact :

Re: Erreur de base de données

Message par gugus2000 » 15 févr. 2020, 15:16

J'ai rien dit, c'est 'id_eve' qui est concerné :/ (je ne sais pas lire un message d'erreur :D )
Cette erreur arrive souvent lorsque on met un string qui contient un int au lieu d'un int tout court (quelle API est utilisé? PDO ou mysqli?)
Gugus2000, pour vous servir !
(propriétaire du gugusmagnus2 et du Destroyer GKU II TX3)

Répondre